Jump to content
SolusVM Community

Archived

This topic is now archived and is closed to further replies.

Ked

New OpenVZ VM Offline & won't start [Solved]

Recommended Posts

This issue threw me for a while so I thought I'd write up the experience here for reference.

 

I had a problem with new containers created via the WHMCS solusvmpro module not starting (although in the end it was not WHMCS releated):

 

- The container appeared to be setup without error in WHMCS

- After logging in to SolusVM, the container was in the list of VMs but offline

- The container would not start via SolusVM but did not error either

 

I logged in to the OpenVZ node via SSH and tried the following (where 880523 is the container ID):

 

vzctl start 880523

Starting container ...

Container private area /vz/private/880523 does not exist

Warning: distribution not specified in CT config, using defaults from /etc/vz/dists/default

 

I checked:

 

/var/log/vzctl.log

 

and found a series of errors that occured at the time the container was created:

 

2011-04-27T10:28:49+0100 vzctl : CT 880523 : File /etc/vz/conf/ve-vps.basic.conf-sample not found: No such file or directory

2011-04-27T10:28:49+0100 vzctl : CT 880523 : Fix the value of CONFIGFILE in /etc/vz/vz.conf

2011-04-27T10:28:49+0100 vzctl : CT 880523 : Creation of container private area failed

2011-04-27T10:28:49+0100 vzctl : CT 880523 : Container config file does not exist

2011-04-27T10:28:49+0100 vzctl : CT 880523 : Warning: distribution not specified in CT config, using defaults from /etc/vz/dists/default

 

 

So, I took a look in /etc/vz/conf/ and found that ve-vps.basic.conf-sample had at some point been renamed to ve-vps.basic.conf-sample.rpmsave

 

I had done a yum update a while back which had updated the OpenVZ kernel, I can only assume that the sample file got renamed at that point.

 

By copying ve-vps.basic.conf-sample.rpmsave back to ve-vps.basic.conf-sample, container creation started to work properly again.

 

My biggest issue with this is that SolusVM did not pick up that there was any problem and quite happily reported that everything was ok, despite the container creation / boot failing each time.

 

Maybe in the future SolusVM could capture errors in the container creation process, possibly by parsing the vzctl.log to give an indication of this kind of issue.

Share this post


Link to post
Share on other sites

This exact same thing happened to me today and it took me far too long to figure it out. This should be in the wiki if nothing else...

 

It also made me realize I'm starting to rely way too much on SolusVM these days.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.