Jump to content
SolusVM Community

Archived

This topic is now archived and is closed to further replies.

hostgokil

Cannot connect, Please check your connection settings

Recommended Posts

sorry to bump the thread, but I have similar problem.

 

I've installed a master without virtualization. (Is it ok to install this master on an OpenVZ VPS?)

 

When I try to add node on this master it just gives me this error message;

 

Cannot connect, Please check your connection settings

 

I'm pretty sure that everything is correct?

 

Do you guys have any idea why this is occurs?

 

Thanks.

Share this post


Link to post
Share on other sites
check if the lighttpd service is running on the VPS node and if you access it https://vpsnodeip:6767/command.php. Also check if the id and key are correct and check if you can connect from the master to the VPS node (open the outbound firewall ports for example).

 

Thank you for the reply.

 

when I try to hit the address that you've stated it gave me this output;

 

ERROR:3

 

And the weird thing is I can add the same node from another Master SolusVM with virtualization.

 

But I cant add that node to a Master SolusVM without virtualization, which is installed on a VPS.

Share this post


Link to post
Share on other sites

Hi

Make sure that the master without virtualization allows the port 6767 and change on the VPS slave /usr/local/solusvm/data/allow.dat the master IP in the IP from the master without virtualization.

Share this post


Link to post
Share on other sites
Hi

Make sure that the master without virtualization allows the port 6767 and change on the VPS slave /usr/local/solusvm/data/allow.dat the master IP in the IP from the master without virtualization.

 

Thank you.

 

I dont know why /usr/local/solusvm/data/allow.dat this file have had only another masters IP address.

 

I replaced the IP address with the new one, and resolved.

 

Thank you once again.

Share this post


Link to post
Share on other sites
Thank you.

 

I dont know why /usr/local/solusvm/data/allow.dat this file have had only another masters IP address.

 

I replaced the IP address with the new one, and resolved.

 

Thank you once again.

 

Hi

after the first connection from the first master the IP is saved into that file. When you change the masters IP or when you want to use the slave with an other master, you've got to change that IP.

Share this post


Link to post
Share on other sites
Hi

after the first connection from the first master the IP is saved into that file. When you change the masters IP or when you want to use the slave with an other master, you've got to change that IP.

 

I got it.

 

I should think of that.

 

My bad.

Share this post


Link to post
Share on other sites
As yourweb said, check the file /usr/local/solusvm/data/allow.dat after I edit that file with the IP that I want, it was fixed.

 

Good luck.

 

thanks for try to help me but i do that before post this replay and same the problem this file in salve solusvm have the ip for the master soulusvm any other idea :(

Share this post


Link to post
Share on other sites

i do have same problem here with a slave node

After installation of SolusVM with OpenVZ , i can not add it to the master.

 

[[email protected]~]# cat /usr/local/solusvm/data/allow.dat

cat: /usr/local/solusvm/data/allow.dat: No such file or directory

 

default=0

timeout=5

splashimage=(hd0,1)/grub/splash.xpm.gz

hiddenmenu

title OpenVZ (2.6.18-274.3.1.el5.028stab094.3)

root (hd0,1)

kernel /vmlinuz-2.6.18-274.3.1.el5.028stab094.3 ro root=/dev/md1 selinu$

initrd /initrd-2.6.18-274.3.1.el5.028stab094.3.img

title CentOS (2.6.18-274.3.1.el5)

root (hd0,1)

kernel /vmlinuz-2.6.18-274.3.1.el5 ro root=/dev/md1

initrd /initrd-2.6.18-274.3.1.el5.img

title CentOS (2.6.18-238.9.1.el5)

root (hd0,1)

kernel /vmlinuz-2.6.18-238.9.1.el5 ro root=/dev/md1

initrd /initrd-2.6.18-238.9.1.el5.img

title CentOS (2.6.18-238.el5)

root (hd0,1)

kernel /vmlinuz-2.6.18-238.el5 ro root=/dev/md1

Share this post


Link to post
Share on other sites

Hello

i have same the problem what can i do please help me

 

First time of all the success,Add NODE ok ~

Then I reinstall the main control in the same IP address again, the controlled is not installed, and then add the node failure

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.