Jump to content
SolusVM Community

Archived

This topic is now archived and is closed to further replies.

vj0R

no bootable device

Recommended Posts

Hello everybody!

I want to boot from * .iso

Do so: media->add iso. Write Name, Description, choose Status Active Arch x86-64 PAE Off. Next Media->Media sync Create next ISOS Select Create Sync Job. Next

Add virtual Server -> KVM . Chose Hostname, ISO mynameiso, Hdd Space, RAM, Swap, Bandwidth, CPU Cores -> Create Virtual Server

Next settings -> Boot Order (1)CDROM (2)HardDisk , CDROM mount mynameiso, NIC Card virtio, Disk Driver virtio

Next boot server and then got a problem "no bootable device"

Please tell me what I'm doing wrong?

 

config:

 

<domain type='kvm'>

<name>kvm106</name>

<uuid>85bbf52c-4561-42d6-aa55-57affb8bd8ab</uuid>

<memory>1048576</memory>

<currentMemory>1048576</currentMemory>

<memtune>

<hard_limit>1099776</hard_limit>

</memtune>

<vcpu>2</vcpu>

<cpu>

</cpu>

<os>

<type machine='pc'>hvm</type>

<boot dev='cdrom'/>

<boot dev='hd'/>

</os>

<clock sync='localtime'/>

<devices>

<emulator>/usr/libexec/qemu-kvm</emulator>

<graphics type='vnc' port='5906' passwd='pass' listen='0.0.0.0'/>

<disk type='file' device='disk'>

<source file='/dev/ws/kvm106_img'/>

<target dev='hda' bus='virtio'/>

</disk>

<disk type='file' device='cdrom'>

<source file='/home/solusvm/kvm/iso/file.iso'/>

<target dev='hdc'/>

<readonly/>

</disk>

<interface type='bridge'>

<model type='virtio' />

<source bridge='br0'/>

<target dev='kvm106.0'/>

<mac address='00:16:3c:4b:e4:80'/>

</interface>

<input type='tablet'/>

<input type='mouse'/>

</devices>

<features>

<acpi/>

<apic/>

</features>

<on_poweroff>destroy</on_poweroff>

<on_reboot>restart</on_reboot>

</domain>

Share this post


Link to post
Share on other sites

Hi. I ask forgiveness for the long answer.

when I start the virtual machine writes to the log:

grep -i 'error' /var/log/libvirt/libvirtd.log

2014-10-05 11:20:33.241+0000: 1779: error : qemuMonitorIO:614 : internal error End of file from monitor

Share this post


Link to post
Share on other sites

Hello,

 

Please check your ISO file status with the following command.( On your slave node)

ls -ld /home/solusvm/kvm/iso/file.iso

 

And provide me full logs from your server while starting the VPS.

 

tail -f /var/log/libvirt/libvirtd.log

Share this post


Link to post
Share on other sites

ls -ld /home/solusvm/kvm/iso/file.iso

-rwxrwxrwx 1 qemu qemu 345 Oct 3 11:18 /home/solusvm/kvm/iso/file.iso

 

tail -f /var/log/libvirt/libvirtd.log

2014-10-03 11:06:48.277+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 11:09:35.906+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 11:16:45.327+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 11:24:10.216+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 13:01:38.999+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 13:04:09.352+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 13:08:01.777+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-03 16:59:37.738+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-05 11:00:07.858+0000: 1779: info : libvirt version: 0.10.2, package: 29.el6_5.12 (CentOS BuildSystem <http://bugs.centos.org>, 2014-09-01-13:44:02, c6b8.bsys.dev.centos.org)

2014-10-05 11:00:07.858+0000: 1779: error : qemuMonitorIO:614 : internal error End of file from monitor

2014-10-05 14:07:46.179+0000: 1779: error : qemuMonitorIO:614 : internal error End of file from monitor

Share this post


Link to post
Share on other sites

tail -f /var/log/libvirt/libvirtd.log
2014-10-03 11:16:45.327+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-03 11:24:10.216+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-03 13:01:38.999+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-03 13:04:09.352+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-03 13:08:01.777+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-03 16:59:37.738+0000: 1731: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-05 11:00:07.858+0000: 1779: info : libvirt version: 0.10.2, package: 29.el6_5.12 (CentOS BuildSystem < >, 2014-09-01-13:44:02,  )
2014-10-05 11:00:07.858+0000: 1779: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-05 14:07:46.179+0000: 1779: error : qemuMonitorIO:614 : internal error End of file from monitor
2014-10-05 18:15:52.232+0000: 1779: error : qemuMonitorIO:614 : internal error End of file from monitor

 

ls -ld /home/solusvm/kvm/iso/file.iso 
-rwxrwxrwx 1 qemu qemu 345 Oct  3 11:18 /home/solusvm/kvm/iso/file.iso

Share this post


Link to post
Share on other sites

virt-install -n testvirt --ram 1024 --arch=x86_64 \
--vcpus=1 --cpu host --check-cpu \
--os-type linux --os-variant=rhel6 --boot cdrom,hd,menu=on \
--disk pool=guest_images_dir,size=10,bus=virtio \
--network=bridge:br0,model=virtio \
--graphics vnc,listen=0.0.0.0,keymap=ru,password=pass \
--noautoconsole --watchdog default,action=reset --virt-type=kvm \
--autostart --cdrom /home/solusvm/kvm/iso/file.iso

virsh -c qemu: /// system list --all 
ID  Name  Status 
-------------------------------------------------- - 
1   kvm102   running
2   testvirt   running

virsh vncdisplay testvirt
:1

ssh root@192.168.3.114 -L 1994:127.0.0.1:5901 && vncviewer localhost:1994

 

I see the same problem

"Boot failed: Could not read from CDROM (code 0003)

No bootable device".

 

 

 

virt-install -n testvirt2 --disk pool=guest_images_dir,size=8 --ram 512 --os-type linux --os-variant=rhel6 --network=bridge:br0 --nographics --cdrom=/home/solusvm/kvm/iso/FreePBX-STABLE64.iso

SeaBIOS (version seabios-0.6.1.2-28.el6)
Machine UUID 12e4efa4-6fcc-af36-fd44-a941139845b2


gPXE () - 00:03.0 C100 PCI2.10 PnP BBS PMM1FE0@10 C100


Booting from DVD/CD...
Boot failed: Could not read from CDROM (code 0003)
Booting from Hard Disk...
Boot failed: not a bootable disk

Booting from ROM...
gPXE (PCI 00:03.0) starting execution
gPXE initialising devices...



gPXE 0.9.7 -- Open Source Boot Firmware -- 
Features: HTTP DNS TFTP AoE iSCSI bzImage COMBOOT ELF Multiboot PXE PXEXT

net0: 52:54:00:8b:6c:fa on PCI00:03.0 (open)
 [Link:up, TX:0 TXE:0 RX:0 RXE:0]
Waiting for link-up on net0... ok
DHCP (net0 52:54:00:8b:6c:fa).... ok
net0: 192.168.3.130/255.255.255.0 gw 192.168.3.1
Filename: 
tftp://0.0.0.0/............. Connection timed out (0x4c126035)
Could not load tftp://0.0.0.0/: Connection timed out (0x4c126035)
No more network devices

Booting from Floppy...                   
Boot failed: could not read the boot disk

No bootable device.

help solve this problem

Share this post


Link to post
Share on other sites

virt-install -n testvirt2 --disk pool=guest_images_dir,size=8 --ram 512 --os-type linux --os-variant=rhel6 --network=bridge:br0 --nographics --cdrom=/home/solusvm/kvm/iso/FreePBX-STABLE64.iso

SeaBIOS (version seabios-0.6.1.2-28.el6)
Machine UUID 12e4efa4-6fcc-af36-fd44-a941139845b2


gPXE (http://etherboot.org) - 00:03.0 C100 PCI2.10 PnP BBS PMM1FE0@10 C100


Booting from DVD/CD...
Boot failed: Could not read from CDROM (code 0003)
Booting from Hard Disk...
Boot failed: not a bootable disk

Booting from ROM...
gPXE (PCI 00:03.0) starting execution
gPXE initialising devices...



gPXE 0.9.7 -- Open Source Boot Firmware -- http://etherboot.org
Features: HTTP DNS TFTP AoE iSCSI bzImage COMBOOT ELF Multiboot PXE PXEXT

net0: 52:54:00:8b:6c:fa on PCI00:03.0 (open)
 [Link:up, TX:0 TXE:0 RX:0 RXE:0]
Waiting for link-up on net0... ok
DHCP (net0 52:54:00:8b:6c:fa).... ok
net0: 192.168.3.130/255.255.255.0 gw 192.168.3.1
Filename: 
tftp://0.0.0.0/............. Connection timed out (0x4c126035)
Could not load tftp://0.0.0.0/: Connection timed out (0x4c126035)
No more network devices

Booting from Floppy...                   
Boot failed: could not read the boot disk

No bootable device.

 

help solve this problem

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.