Jump to content
SolusVM Community
Sign in to follow this  
xdr

Master SolusVM, problem with slave

Recommended Posts

Hello 
 
I had to reinstall my solusvm master from scratch and now I can not get the list of virtual machines that are in my solusvm slave ... can you give me information about this?
 
I can not manage my vps, restart, suspend or edit them. I add my solusvm slave, detect  memory usage, disk usage, but cannot see the virtual machines.

thanks for you help
xdr

Share this post


Link to post
Share on other sites

Hi Xdr,

 

The slave is a bit dumb. It only acts when it receives a command from the master. Only the master knows all the details about the VM and what actually runs on the server. Unfortunately, since you have reinstalled the master, this data is gone. Luckily for you SolusVM features an import mode which can import the VM to your panel. See https://documentation.solusvm.com/display/DOCS/Importing+Virtual+Servers+into+SolusVMfor more information?

 

 

Did you change the masters IP? Update /usr/local/solusvm/data/allow.dat with the new IP on every slave.

Share this post


Link to post
Share on other sites

Hi,

 

You said that you created the Master from the scratch, so before doing this, did you have the Database backup?  if not, it you will have to import all the VMS into it it.  Go to setting, enable import tool option, and start creating the database entries for the VPSs.  It will not overwrite  your VPSs, but will only let the master know about their presence in the cluster..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.